OruxMaps
Visit the new forum: <a href="http://www.oruxmaps.com/foro">OruxMaps</a>

fallo cartografia Rmap con la ultima version

Go down

fallo cartografia Rmap con la ultima version

Post  marcossf on Mon May 06, 2013 8:04 am

Hasta ahora los mapas rmap que tengo en el movil funcionaban estupendamente hasta la version 5.2.3 (marzo), pero tras la actualización a la ultima version, me encuentro que carga el mapa en donde el gps detecta pero al intentar cambiar la escala a mas o menos, empieza a dibujar un mapa de "relieve?" de color verde, y a partir de ahi ya no hay manera.

Me bajé la version 4.8.64 para al menos poder ir a la ruta planificada del fin de semana y los mapas funcionan perfectamente, cambian de escala y saltan la cuadricula correctamente.

En la version 5.2.3 tambien funcionaba estupendamente incluso con datos DEM obtenidos desde high altitude con el mapa en 3D.

Probe a bajar la Beta 5.2.5 y me hace lo mismo.

No sé que cambio se habrá hecho en la aplicación pero desde luego no va, y tampoco sé de donde bajar la 5.2.3 que si me funcionaba estupendamente antes de actualizarse.

Movil: Sony Xperia Arc 4.0.4 root ROM oficial.

Orux, soy Marcos, el que te hizo de betatester del pulsometro ANT+ hace ya tiempo. Wink

marcossf

Cantidad de envíos : 14
Fecha de inscripción : 2011-09-30

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  lalfonsoperez on Mon May 06, 2013 11:14 am

Buenos días, soy nuevo en el foro pero llevo usando tiempo Oruxmaps.

Aporto más información acerca de este error, que por cierto es el mismo que expresa nuestro compañero "geochema" en el post anterior "No funcionan correctamente las capas en ZTE Skate". Lo que me ocurre a mi, y supongo que a vosotros también es que al cargar un mapa guardado (generalmente en formato RMAP) se carga la capa en el zoom más ampliado y le asigna el valor 0 (el numerito pequeño que aparece en la parte inferior sobre el valor del zoom digital que suele ser 100). Entonces, al alejar la capa con el pellizco, asigna numeros inferiores (-1, -2, -3, -4 ...) y si intentamos ampliar la capa asigna el número 1, por lo que carga automáticamente el mapa world (su nivel de capa es 1). Si pellizcas para alejar desde el mapa world volverá a cargar el mapa que tenias anteriormente.

En las versiones anteriores asignaba correctamente este valor de capa, que dependiendo de la resolución del mapa suele ir desde 11 o 12 hasta 18 o 20 y por tanto funcionaba correctamente el cambio entre capas, pero ahora, al asignar valor 0 a todas las capas, no es posible pasar entre mapas guardados con distinto nivel de zoom para la misma zona y cuando pasas del zoom máximo, cargará el mapa world.

No se exactamente en que actualización se ha producido este error, pero en la versión 4.8.64 no existía y funcionaba todo correctamente.

Un Saludo

Movil: Samsung Galaxy SII, Android 4.1.2 ROM oficial Samsung.

lalfonsoperez

Cantidad de envíos : 2
Fecha de inscripción : 2013-05-06

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  marcossf on Mon May 06, 2013 5:10 pm

Al menos en la actualización de marzo todo iba bien. Ha sido desde este update y la beta publicada también. A ver si Orux ve el fallo rápidamente o nos comenta como solucionarlo.



marcossf

Cantidad de envíos : 14
Fecha de inscripción : 2011-09-30

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  orux on Mon May 06, 2013 5:37 pm

lalfonsoperez wrote:Buenos días, soy nuevo en el foro pero llevo usando tiempo Oruxmaps.

Aporto más información acerca de este error, que por cierto es el mismo que expresa nuestro compañero "geochema" en el post anterior "No funcionan correctamente las capas en ZTE Skate". Lo que me ocurre a mi, y supongo que a vosotros también es que al cargar un mapa guardado (generalmente en formato RMAP) se carga la capa en el zoom más ampliado y le asigna el valor 0 (el numerito pequeño que aparece en la parte inferior sobre el valor del zoom digital que suele ser 100). Entonces, al alejar la capa con el pellizco, asigna numeros inferiores (-1, -2, -3, -4 ...) y si intentamos ampliar la capa asigna el número 1, por lo que carga automáticamente el mapa world (su nivel de capa es 1). Si pellizcas para alejar desde el mapa world volverá a cargar el mapa que tenias anteriormente.

En las versiones anteriores asignaba correctamente este valor de capa, que dependiendo de la resolución del mapa suele ir desde 11 o 12 hasta 18 o 20 y por tanto funcionaba correctamente el cambio entre capas, pero ahora, al asignar valor 0 a todas las capas, no es posible pasar entre mapas guardados con distinto nivel de zoom para la misma zona y cuando pasas del zoom máximo, cargará el mapa world.

No se exactamente en que actualización se ha producido este error, pero en la versión 4.8.64 no existía y funcionaba todo correctamente.

Un Saludo

Movil: Samsung Galaxy SII, Android 4.1.2 ROM oficial Samsung.

Gracias;

Habéis dado en el clavo; no encontraba el problema; ocurre con los mapas en formato rmap, lo corrijo y esta noche subo otra beta,

orux

_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
avatar
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  marcossf on Tue May 07, 2013 9:33 am

Gracias Orux!

Avísanos cuando tengas subida la corrección Wink

Me puedes indicar donde puedo bajar el apk de la 5.2.3?

Como sugerencia en un futuro podrías hacer que funcionaran como links las versiones del marco Novedades de la pagina principal y se mostrase las mejoras de esa versión (changelog) ademas de poder descargar desde ahí cualquier versión antigua.


marcossf

Cantidad de envíos : 14
Fecha de inscripción : 2011-09-30

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  orux on Tue May 07, 2013 4:58 pm

marcossf wrote:Gracias Orux!

Avísanos cuando tengas subida la corrección Wink

Me puedes indicar donde puedo bajar el apk de la 5.2.3?

Como sugerencia en un futuro podrías hacer que funcionaran como links las versiones del marco Novedades de la pagina principal y se mostrase las mejoras de esa versión (changelog) ademas de poder descargar desde ahí cualquier versión antigua.


Hola,

la última debe funcionar bien-->www.oruxmaps.com/cs

las anteriores versiones no las tengo descargables en la web, cuando las tenía la gestión de versiones era un poco caos.

pero la beta última es suficiente estable, la puedes usar con garantías,

orux

_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
avatar
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  marcossf on Tue May 07, 2013 5:26 pm

Acabo de probar la ultima beta 5.2.5beta5 con mi cartografía en rmap y me sigue cargando el mapa de relieve nada mas hacer zoom o cambiar de tesela, incluso reiniciando la bbdd de mapas y deshabilitando la opción en la configuración de mapa de relieve, sigue saliendo un relieve verde, y ya no sale mas el mapa si no lo cargo manualmente de nuevo.


Si cargo el mapa a mano, lo carga bien, y al hacer zoom entre capas al llegar a la menor me saca el mapa de relieve y ya no hay manera.

marcossf

Cantidad de envíos : 14
Fecha de inscripción : 2011-09-30

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  orux on Tue May 07, 2013 5:27 pm

marcossf wrote:Acabo de probar la ultima beta 5.2.5beta5 con mi cartografía en rmap y me sigue cargando el mapa de relieve nada mas hacer zoom o cambiar de tesela, incluso reiniciando la bbdd de mapas y deshabilitando la opción en la configuración de mapa de relieve, sigue saliendo un relieve verde, y ya no sale mas el mapa si no lo cargo manualmente de nuevo.


Si cargo el mapa a mano, lo carga bien, y al hacer zoom entre capas al llegar a la menor me saca el mapa de relieve y ya no hay manera.

Después de deshabilitar el mapa de relieve, reinicia otra vez el listado de mapas, ahora debe no volver a cargar ese mapa.

pero lo que comentas es normal (zoom hacia abajo) si el mapa de relieve existe en niveles de zoom inferiores (más detallado).

orux

_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
avatar
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  marcossf on Tue May 07, 2013 5:35 pm

ok, ahí esta el truco. una vez deshabilitado el mapa de relieve, y regenerar la bbdd de mapas ya me carga los mapas y las capas funcionan como deben. Me estaba volviendo loco.

Ahora por lo que veo, en visualización 3d no tengo el relieve de todas las teselas, como si cargase solo zonas con datos DEM, a pesar de tener todos descargados. Pero bueno eso no es tan importante, ya me funciona lo demás.

Gracias Orux, eres una maquina.

marcossf

Cantidad de envíos : 14
Fecha de inscripción : 2011-09-30

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  orux on Tue May 07, 2013 5:40 pm

marcossf wrote:ok, ahí esta el truco. una vez deshabilitado el mapa de relieve, y regenerar la bbdd de mapas ya me carga los mapas y las capas funcionan como deben. Me estaba volviendo loco.

Ahora por lo que veo, en visualización 3d no tengo el relieve de todas las teselas, como si cargase solo zonas con datos DEM, a pesar de tener todos descargados. Pero bueno eso no es tan importante, ya me funciona lo demás.

Gracias Orux, eres una maquina.

Gracias, se hace lo que se puede Smile

Para verificar si los ficheros DEM son buenos (los hay malos), desplaza el mapa, en el visor, y vas abriendo la vista 3D. Si el fichero DEM del centro del mapa no es bueno, te pedirá descargarlo.


orux


_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
avatar
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  marcossf on Tue May 07, 2013 6:26 pm

Efectivamente. Sale mal en algunas teselas, porque hace barrancos en los bordes entre ellas. Lo que no me pide es descargarlas. Tengo DEM1 y High Altitude, aunque solo se usar lo básico de estos complementos.

marcossf

Cantidad de envíos : 14
Fecha de inscripción : 2011-09-30

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  marcossf on Tue May 07, 2013 6:56 pm

Bueno, peleándome un rato he conseguido que tenga unos buenos DEM. Aparentemente todo funciona, listo para la ruta del sábado!!

marcossf

Cantidad de envíos : 14
Fecha de inscripción : 2011-09-30

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  janes on Fri May 24, 2013 8:28 am

orux wrote:
marcossf wrote:Acabo de probar la ultima beta 5.2.5beta5 con mi cartografía en rmap y me sigue cargando el mapa de relieve nada mas hacer zoom o cambiar de tesela, incluso reiniciando la bbdd de mapas y deshabilitando la opción en la configuración de mapa de relieve, sigue saliendo un relieve verde, y ya no sale mas el mapa si no lo cargo manualmente de nuevo.


Si cargo el mapa a mano, lo carga bien, y al hacer zoom entre capas al llegar a la menor me saca el mapa de relieve y ya no hay manera.

Después de deshabilitar el mapa de relieve, reinicia otra vez el listado de mapas, ahora debe no volver a cargar ese mapa.

pero lo que comentas es normal (zoom hacia abajo) si el mapa de relieve existe en niveles de zoom inferiores (más detallado).

orux

he deshabilitado Configuracion>Mapas>Relief map
he regenerado BD mapas
y me sigue dando el error de zoom 0 en los RMAP

este truco solo funciona en la beta? tengo la v.5.2.4

gracias

janes

Cantidad de envíos : 20
Fecha de inscripción : 2013-02-16

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  orux on Mon May 27, 2013 10:30 am

janes wrote:
orux wrote:
marcossf wrote:Acabo de probar la ultima beta 5.2.5beta5 con mi cartografía en rmap y me sigue cargando el mapa de relieve nada mas hacer zoom o cambiar de tesela, incluso reiniciando la bbdd de mapas y deshabilitando la opción en la configuración de mapa de relieve, sigue saliendo un relieve verde, y ya no sale mas el mapa si no lo cargo manualmente de nuevo.


Si cargo el mapa a mano, lo carga bien, y al hacer zoom entre capas al llegar a la menor me saca el mapa de relieve y ya no hay manera.

Después de deshabilitar el mapa de relieve, reinicia otra vez el listado de mapas, ahora debe no volver a cargar ese mapa.

pero lo que comentas es normal (zoom hacia abajo) si el mapa de relieve existe en niveles de zoom inferiores (más detallado).

orux

he deshabilitado Configuracion>Mapas>Relief map
he regenerado BD mapas
y me sigue dando el error de zoom 0 en los RMAP

este truco solo funciona en la beta? tengo la v.5.2.4

gracias

Está corregido en las betas de la próxima versión-->www.oruxmaps.com/cs

orux

_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
avatar
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

View user profile

Back to top Go down

Re: fallo cartografia Rmap con la ultima version

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum