OruxMaps
Visit the new forum: <a href="http://www.oruxmaps.com/foro">OruxMaps</a>

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  potifa on Wed Jan 16, 2013 8:21 pm

Hey Orux,

I'm very happy about the extended functionality of version 5.0. Eventually, you've written a killer application. Just have a look at the new Garmin devices presented at CES. The only thing they can better is battery life - and that's nothing you're accountable for.

That said, I encounter a problem. I have a Sony Xperia Ray which includes the ANT+ Radio Service. I meanwhile deinstalled these updates and reinstalled them again. I can identify the heart rate belt (from O_Synce) in IPSensorMan and entered the ID in Oruxmaps. When I start ANT+ in Oruxmaps afterwards, the program says in order to establish a connection with ANT+, ANT+ Radio Service needs to be installed and forwards me to the PlayStore. Yet as I said: The service is installed.

I downloaded Endomondo Sports Tracker for a cross check and find that the program recognizes the belt easily. I therefore can conclude that the program is nested within Oruxmaps. Any idea how to solve this?

Best wishes
Thomas

potifa

Cantidad de envíos : 20
Fecha de inscripción : 2012-10-01

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  orux on Thu Jan 17, 2013 9:04 pm

potifa wrote:Hey Orux,

I'm very happy about the extended functionality of version 5.0. Eventually, you've written a killer application. Just have a look at the new Garmin devices presented at CES. The only thing they can better is battery life - and that's nothing you're accountable for.

That said, I encounter a problem. I have a Sony Xperia Ray which includes the ANT+ Radio Service. I meanwhile deinstalled these updates and reinstalled them again. I can identify the heart rate belt (from O_Synce) in IPSensorMan and entered the ID in Oruxmaps. When I start ANT+ in Oruxmaps afterwards, the program says in order to establish a connection with ANT+, ANT+ Radio Service needs to be installed and forwards me to the PlayStore. Yet as I said: The service is installed.

I downloaded Endomondo Sports Tracker for a cross check and find that the program recognizes the belt easily. I therefore can conclude that the program is nested within Oruxmaps. Any idea how to solve this?

Best wishes
Thomas

Hi, Thomas;

I do not know where is the problem.

I think people is using ant+ with no problems.

I am testing ANT+ with an USB stick.

This message comes from the ANT+ library, when the ANT+ service can not be started.

Check that you do not have an application that closes or do not releases the interface,

orux



_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
orux
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  potifa on Fri Jan 18, 2013 9:46 am

Hey Orux,

Your reply first left me a bit demotivated, but I didn't want to give up that easily. I tested around a bit. Uninstalled IPSensorMan, re-installed, checked with IP Bike, bla bla bla. Eventually, I uninstalled Oruxmaps completely and re-installed it. Guess what? It works. Before, I used a rather old version of OruxMaps. Maybe something went wrong in the update.

Thanks again for this wonderful app. I'm very curious to experience the ANT+ functionality. Going to submit a well-deserved donation.

Best wishes
Thomas

potifa

Cantidad de envíos : 20
Fecha de inscripción : 2012-10-01

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  vicious cycle on Sun Mar 31, 2013 8:33 pm

orux wrote:
I am testing ANT+ with an USB stick.


is there a plan for ΑΝΤ+ usb support?
more and more phones offer usb host functionality and sony is, seemingly, fading out integrated ant+ radio from it's newer models.
so it would make some sense and is hopefully not too much work. (ipbike is the only app that supports usb ant+ thus far)

vicious cycle

Cantidad de envíos : 3
Fecha de inscripción : 2012-08-01

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  orux on Mon Apr 01, 2013 3:09 pm

vicious cycle wrote:
orux wrote:
I am testing ANT+ with an USB stick.


is there a plan for ΑΝΤ+ usb support?
more and more phones offer usb host functionality and sony is, seemingly, fading out integrated ant+ radio from it's newer models.
so it would make some sense and is hopefully not too much work. (ipbike is the only app that supports usb ant+ thus far)


Hi;


I am developing ANT+ features with an USB stick and some ANT+ devices.

It should work normally.

orux


_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
orux
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  vicious cycle on Tue Apr 02, 2013 6:29 am

I'm using a Samsung Note (N7000) and a suunto movestick mini as ant+.
trying to pair with a hrm belt (from ciclosport)

they seem to work ok when using ipbike.
I have manually entered the Heart Monitor ID in the ant+ sensor menu.
in the heart monitor menu I've left everything unchanged.
that's pretty much it.
what else should I be doing?

PS feel free to move my posts to a different thread if you think they 're not that relevant.


edit
I cleared the data of ant radio service and it's working as it should now cheers


Last edited by vicious cycle on Tue Apr 02, 2013 8:17 pm; edited 1 time in total (Reason for editing : solved)

vicious cycle

Cantidad de envíos : 3
Fecha de inscripción : 2012-08-01

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Ant+ speed and cadence sensors not working

Post  hoderlump on Sat Apr 06, 2013 2:28 pm

hey Orux!

I am really happy about your app. I have to say it took me some time to get going with it but now as spring is coming I want to use it as a tachometer on my bike as it is the only app out there integrating the Xperia Active's barometer and ant+ possibilities!

But I cannot get my ant+ sensors working, same problem as user vicious above.

My devices are:
- SonyEricsson Xperia Active, newest official Android
- O_Synce Macro2sx speed ant+ speed sensor
- O_Synce Macro2sx cadence ant+ cadence sensor

I pasted the device IDs into the fields in the settings menu and activated ant+. Sometimes there is no error message and the ant+-symbol appears, sometimes there is the error message "ANT+ connection lost! Retrying in 20 seconds". But it never shows any sensor data in the Dashboard or in the Radar.

The sensors work fine in other apps, the ant radio service app always finds the sensors very fast and shows the sensor data.

There seem to be some other people out there who have had this problem, in the Google Play store, some of the comments describe the problem. Some could solve it by deinstalling the Ant+ Radio Sevice updates and Oruxmaps and reinstall them. User vicious above me deleted the data of ant radio service. Nothing helped for me, I tried these things several times in the last weeks and I am really desperate....

Can someone who also has an Xperia give me detailes advice, how to get them working? I am not sure if the Ant Radio Service app has to run in the background or not??
Orux, to help you in developing, I am willing to send you an ant+ sensor, maybe the same as I have just for testing if you want one? I really like your app and appreciate your work!

Thanks, Greetz
Johannes

hoderlump

Cantidad de envíos : 3
Fecha de inscripción : 2013-04-06

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  orux on Sun Apr 07, 2013 5:01 pm

hoderlump wrote:hey Orux!

I am really happy about your app. I have to say it took me some time to get going with it but now as spring is coming I want to use it as a tachometer on my bike as it is the only app out there integrating the Xperia Active's barometer and ant+ possibilities!

But I cannot get my ant+ sensors working, same problem as user vicious above.

My devices are:
- SonyEricsson Xperia Active, newest official Android
- O_Synce Macro2sx speed ant+ speed sensor
- O_Synce Macro2sx cadence ant+ cadence sensor

I pasted the device IDs into the fields in the settings menu and activated ant+. Sometimes there is no error message and the ant+-symbol appears, sometimes there is the error message "ANT+ connection lost! Retrying in 20 seconds". But it never shows any sensor data in the Dashboard or in the Radar.

The sensors work fine in other apps, the ant radio service app always finds the sensors very fast and shows the sensor data.

There seem to be some other people out there who have had this problem, in the Google Play store, some of the comments describe the problem. Some could solve it by deinstalling the Ant+ Radio Sevice updates and Oruxmaps and reinstall them. User vicious above me deleted the data of ant radio service. Nothing helped for me, I tried these things several times in the last weeks and I am really desperate....

Can someone who also has an Xperia give me detailes advice, how to get them working? I am not sure if the Ant Radio Service app has to run in the background or not??
Orux, to help you in developing, I am willing to send you an ant+ sensor, maybe the same as I have just for testing if you want one? I really like your app and appreciate your work!

Thanks, Greetz
Johannes

Hi;

there are some changes with ant+ in the last beta--> www.oruxmaps.com/cs

please, try,

orux

_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
orux
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  hoderlump on Sun Apr 07, 2013 7:27 pm

orux wrote:
Hi;

there are some changes with ant+ in the last beta--> www.oruxmaps.com/cs

please, try,

orux

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed B5a

You, sir, are a wizard!
I downloaded the beta, tested it - it just works. Thanks!! Donation is on it's way!

hoderlump

Cantidad de envíos : 3
Fecha de inscripción : 2013-04-06

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  Goddi8 on Tue May 07, 2013 9:40 pm

Johannes, did you get the cadence sensor working as well?
I have the same setup as yours (w/o Speed sensor) and don't get any data shown in Radar or Dashboard.
I'm using the latest beta

Goddi8

Cantidad de envíos : 4
Fecha de inscripción : 2012-08-30

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  hoderlump on Wed May 08, 2013 8:27 am

Goddi8 wrote:Johannes, did you get the cadence sensor working as well?
I have the same setup as yours (w/o Speed sensor) and don't get any data shown in Radar or Dashboard.
I'm using the latest beta

Hi Goddi!

I sold the cadence sensor meanwhile because I do not get the idea of cadence sensors and I don't need one (maybe someone can explain what this data is useful for??).
As I remember the cadence sensor was working but I'm not 100% sure.

Maybe you should try the same Oruxmaps version that I use? It is v.5.2.4beta8.
Did you enter the ant+ ID of the cadence sensor in the settings?
Did you install all updates to IpSensorMan (link to the software)? Does your sensor work there?

Greetz
Johannes

hoderlump

Cantidad de envíos : 3
Fecha de inscripción : 2013-04-06

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  Goddi8 on Wed May 08, 2013 8:20 pm

Hi Johannes, thanks.
Yep, it works in IPSensorMan.
I will try to get the old beta and give it a shot

Goddi8

Cantidad de envíos : 4
Fecha de inscripción : 2012-08-30

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  fabrylama on Wed May 08, 2013 11:01 pm

Goddi8 wrote:Hi Johannes, thanks.
Yep, it works in IPSensorMan.
I will try to get the old beta and give it a shot

Hi, I use oruxmaps from the market and cadence works fine, what brand of sensor do you use? Have you entered the sensor ID in oruxmaps' ant+ menu?

fabrylama

Cantidad de envíos : 96
Fecha de inscripción : 2012-06-25

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  Goddi8 on Thu May 09, 2013 10:19 am

Hi,

I'm using this one: O_Synce Macro2sx cadence ant+ cadence sensor
Tried with and w/o ID. Funnily even if using a wrong ID oruxmaps says sucessfully connected.

Goddi8

Cantidad de envíos : 4
Fecha de inscripción : 2012-08-30

Back to top Go down

Oruxmaps calls for installation of ANT+ Radio Service despite this being installed Empty Re: Oruxmaps calls for installation of ANT+ Radio Service despite this being installed

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum