OruxMaps
Visit the new forum: <a href="http://www.oruxmaps.com/foro">OruxMaps</a>

Problem loading correct map when selecting waypoints

Go down

Problem loading correct map when selecting waypoints Empty Problem loading correct map when selecting waypoints

Post  droolian01 on Thu Jul 15, 2010 3:46 pm

Hello

This problem only occurs when you try to select a waypoint that is not on the current map displayed.

So, if you DO have the correct map displayed you can show a waypoint on the map in 2 ways:

1) use the "Route" button on the screen > select the waypoint from the list > oruxmaps then takes you to the waypoint pin correctly on the map

2) select "menu" > select "waypoint" > select the waypoint from the list > select "load in map" > oruxmaps then takes you to the waypoint pin correctly on the map

This is all good and seems to work well.

But...if you have the WRONG map selected initially, method 1 (via "Route" on screen button) still works but method 2 (via "menu" > "waypoints" etc) puts the marker pin in totally the wrong place! The Coordinates at the bottom of the screen are correct, and moving the map around with my finger changes the coordinates appropriately. It just seems that the incorrect map is loaded. Also, with other waypoints a blank screen is displayed (likely that oruxmaps tries to go to a point that i don't have a map for).

Not a huge issue, and oruxmaps is still a brilliant piece of software, as long as i remember to use only method 1 with my waypoints!

Hope this is helpfull

p.s. i am using a samsung galaxy s (i9000) on eclair firmware version2.1-update 1
maps - source=OS 1:25000 bmp calibrated with ozimaps to a .map file, then converted with oruxmaps desktop
Waypoints - source= ported from old phone (sony ericsson P1i running SmartcomGPS software) as .wpt files, converted into .gpx (xml) with GPSbabel, then put into sdcard/oruxmaps/tracklog folder on the samsung galaxy s


droolian01

Cantidad de envíos : 2
Fecha de inscripción : 2010-07-15

Back to top Go down

Problem loading correct map when selecting waypoints Empty Re: Problem loading correct map when selecting waypoints

Post  orux on Thu Jul 15, 2010 5:07 pm

droolian01 wrote:Hello

This problem only occurs when you try to select a waypoint that is not on the current map displayed.

So, if you DO have the correct map displayed you can show a waypoint on the map in 2 ways:

1) use the "Route" button on the screen > select the waypoint from the list > oruxmaps then takes you to the waypoint pin correctly on the map

2) select "menu" > select "waypoint" > select the waypoint from the list > select "load in map" > oruxmaps then takes you to the waypoint pin correctly on the map

This is all good and seems to work well.

But...if you have the WRONG map selected initially, method 1 (via "Route" on screen button) still works but method 2 (via "menu" > "waypoints" etc) puts the marker pin in totally the wrong place! The Coordinates at the bottom of the screen are correct, and moving the map around with my finger changes the coordinates appropriately. It just seems that the incorrect map is loaded. Also, with other waypoints a blank screen is displayed (likely that oruxmaps tries to go to a point that i don't have a map for).

Not a huge issue, and oruxmaps is still a brilliant piece of software, as long as i remember to use only method 1 with my waypoints!

Hope this is helpfull

p.s. i am using a samsung galaxy s (i9000) on eclair firmware version2.1-update 1
maps - source=OS 1:25000 bmp calibrated with ozimaps to a .map file, then converted with oruxmaps desktop
Waypoints - source= ported from old phone (sony ericsson P1i running SmartcomGPS software) as .wpt files, converted into .gpx (xml) with GPSbabel, then put into sdcard/oruxmaps/tracklog folder on the samsung galaxy s


Hi, droolian01;

Hmmmm, you are right;

there is a bug if only one new map which contains the wpt is found.

I will solve this problem with next version.

orux


_________________
Ahora puedes contribuir:--> DONACIÓN
Now you can contribute:--> DONATE
orux
orux

Cantidad de envíos : 3946
Fecha de inscripción : 2009-07-06

Back to top Go down

Problem loading correct map when selecting waypoints Empty Re: Problem loading correct map when selecting waypoints

Post  droolian01 on Fri Jul 16, 2010 12:50 pm

Hi Orux

Thankyou for looking into this, and thankyou for producing such a brilliant app!

droolian01
Very Happy

droolian01

Cantidad de envíos : 2
Fecha de inscripción : 2010-07-15

Back to top Go down

Problem loading correct map when selecting waypoints Empty Map issue

Post  polygonw on Wed Jul 21, 2010 11:52 am

Hi,

I encounter a similar problem with Oruxmaps on a Samsung Galaxy i9000 : I created a OSM map with Mobile Atlas creator and loaded it onto the mobile. When loading a GPX track, it shows correctly on all levels upto 12, from zoom level 13 and higher, the coordinates are shifted. Hovering over a reference point on the map shows different coordinates between level 12 and 13. I tried this with several sources of OSM data. It shows correctly on the PC screen in Mobile Atlas creator.

Any help would appreciated. Otherwise, the application is very good. This can really make me replace my Garmin ...

Ronny

polygonw
Guest


Back to top Go down

Problem loading correct map when selecting waypoints Empty Extra info

Post  polygonw on Wed Jul 21, 2010 12:12 pm

Hi,

Though I prefer OSM maps, I also tried the same with Google map data, and the bug is consistent : going from zoom level 12 to 13, the map 'jumps' and the tracks don't show correctly anymore.
Hope this helps.

Ronny

polygonw
Guest


Back to top Go down

Problem loading correct map when selecting waypoints Empty Re: Problem loading correct map when selecting waypoints

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum